Moodle 3.4 or later requires at least PHP 7.0.0 (currently using version 5.4.45-0+deb7u14). Some servers may have multiple PHP versions installed, are you using the correct executable?